Ahogyan a klasszikus vicc kezdődik a kollégista táviratával: “Anyám, szivatnak. Stop.” – nagyjából ezt éreztem a WordPress új, “várva várt” nagyverziójának tesztelésekor. Nem vagyok az újdonságok ellenzője, de jelen esetben két zavaró érzésem is van: elrontottak valamit, ami jó volt, és fantasztikus újdonságként ujjonganak valamiért, amely évek óta elérhető, ha nem is a WordPress alapfunkciói között.

Szokás szerint egy jazz-zenész, ezúttal a kubai Bebo Valdés a nagyverzió névadója – aki többnyire vidám, kellemes jazzt játszott, élvezet hallgatni. Sajnos sokkal kevésbé élvezetes a WP 5.0 nagy újdonsága, a Gutenberg szerkesztő… 🙁

WordPress 5.0 

A blokkos tartalomszerkesztés csak annak lehet még ismeretlen, aki soha életében nem használt page buildert (mi például éppen négy éve írtunk róluk először ») Ezek az eszközök ugyan többnyire fizetősek (legalábbis a jobbak, mint a Visual Composer, az Avada sablon Fusion Buildere, vagy a Divi Builder), de sokkal-sokkal többet tudnak, és sokkal-sokkal egyszerűbb kezelni őket, mint a WordPressbe mostantól alapértelmezetten beépített Gutenberget. Jelen pillanatban egyetlen pozitívumot tudok elmondani róla: hogy hála az égnek, kikapcsolható.

Ja, nem, még azt is, hogy látványos kisfilmet készítettek róla:

 

Próbáld ki, játssz vele – én őszintén szólva nem szeretem. Page buildert csak a sales oldalakhoz szoktam használni, vagy egyéb különleges esetekben; egy normál blogbejegyzésnél felesleges, és sokkal könnyebb a klasszikus szerkesztő használata. Azonban most, ha frissíted a motort, a bejegyzések és oldalak alatt a Szerkesztés linkre kattintva (vagy új létrehozásakor) csak a blokkos szerkesztővel tudsz dolgozni:

WordPress 5.0 Gutenberg

A korábbi szerkesztő használatához egy bővítményt kell telepítened, a Classic Editort, amelyet a WordPress 2021-ig fog támogatni. (Egyesek szerint ennél kicsit jobb a Classic Editor Addon. Próbáld ki, döntsd el…) A másik megoldás a Disable Gutenberg nevű plugin, ő pedig – minő meglepetés – kikapcsolja a Gutenberget. (Mert amire van igény, arra ugye előbb-utóbb bővítmény is lesz, szoktam mondogatni. És lett is.)

WordPress 5.0

Én egyelőre inkább a határokat látom, nem a határtalan lehetőségeket, de bízzunk benne, hogy ez idővel elmúlik…

Az új verzióhoz új alapsablon is tartozik (értelemszerűen a TwentyNineteen névre hallgat, és eleve a Gutenberg támogatásához készült), de ennyi elég is volt egyszerre, más fejlesztést nem tartalmaz az 5.0.

Ha rám hallgatsz, azt csinálsz, amit akarsz 🙂 – de szerintem érdemes várni egy kicsit, mielőtt éles oldalon frissítesz. Várjuk meg az 5.0.1-et: most, hogy hirtelen százezrek töltik le az 5.0-t, biztosan hamar előjönnek a szokásos gyerekbetegségek. Ha nagyon kíváncsi vagy, akkor pedig gyakorolj vele egy teszt oldalon. Azt ugye már mondanom sem kell, hogy frissítés előtt mindig készíts biztonsági mentést.

Még egy fontos dolog: ha WooCommerce van az oldaladon, először azt frissítsd legalább 3.5.1-re, és csak utána a WordPresst! És ha bármelyik bővítményed furcsán kezdene viselkedni, akkor, amíg ki nem jön hozzá a javítás, a WP Rollback bővítménnyel visszaállíthatod a korábbi változatát.